Werbung


 
Forum  


Seiten: (2) [1] 2  ( Zum ersten neuen Beitrag ) Reply to this topicStart new topicStart Poll

> Juicer - Applejuice Qt Gui
Lestat
Geschrieben am: 04.11.2008, 22:03
Quote Post


Apfelkern


Gruppe: Admin a.D.
Beiträge: 87
Mitgliedsnummer.: 9.386
Mitglied seit: 29.06.2004



Juicer ist eine Applejuice-GUI auf Basis des Open Source Multi-Plattform-Frameworks Qt 4. Juicer läuft daher unter allen Betriebssystemen, für die Qt 4 verfügbar ist, darunter Linux, Windows und MacOS.

Informationen sowie eine FAQ zu Juicer findet ihr auf der offiziellen Seite appleJuicer.net.

Der Download ist direkt von Sourceforge möglich. Neben den Quellen stehen fertig kompilierte Versionen für Windows und Ubuntu Linux zur Verfügung.

Edit: mal das Posting angepasst.


--------------------
From freedom came elegance - Linux Mint 7 Gloria
PMEmail PosterUsers Website
Top
Heino
Geschrieben am: 05.11.2008, 08:08
Quote Post


Apfelplantage


Gruppe: Members
Beiträge: 381
Mitgliedsnummer.: 5.776
Mitglied seit: 21.12.2003



hi sieht gut aus icon_thumbup.gif

hatte es gust mal angetestet und sobutzt ein prob gehabt

habe meine einstellungen unter limits geändert und sie wurden nicht gespeichert und das file im download war danach nicht mehr sichtbar

musste erst juicer wieder neu starten damit ich das file wieder gesehen habe und die neuen einstellungen unter limits bekomme ich nicht gespeichert

benutze win xp
PM
Top
Lestat
Geschrieben am: 05.11.2008, 19:41
Quote Post


Apfelkern


Gruppe: Admin a.D.
Beiträge: 87
Mitgliedsnummer.: 9.386
Mitglied seit: 29.06.2004



Uih. Hast du nur die Limits geändert oder noch was anderes? Genauer Ablauf wäre interessant. Hab das hier gerade unter XP getestet und konnte das Problem nicht reproduzieren.


--------------------
From freedom came elegance - Linux Mint 7 Gloria
PMEmail PosterUsers Website
Top
Heino
Geschrieben am: 05.11.2008, 19:59
Quote Post


Apfelplantage


Gruppe: Members
Beiträge: 381
Mitgliedsnummer.: 5.776
Mitglied seit: 21.12.2003



also ich kann unter einstellungen bei core und limits zwar alles ändern aber nichts speichern
dabei ists egal ob ich den port ändere oder unter limits irgendwas ändere

normal müsste ja auch im corefenster auch ne meldung kommen das er die settings.xml geschrieben hat aber kommt nüscht


komisch ist auch das nachdem ich was geändert habe und auf ok klicker ich danach nichts mehr ändern kann bevor ich nicht juicer neu gestartet habe da alles grau hinterlegt ist siehe pic

user posted image

und sobald ich irgendwo was ändere wird wie gesagt nichts gespeichert aber alle files im download verschwinden und wird erst nach nem neustart wieder sichtbar
PM
Top
moh0815
Geschrieben am: 05.11.2008, 20:12
Quote Post


Jungpflanze


Gruppe: Serverbetreiber
Beiträge: 120
Mitgliedsnummer.: 13.019
Mitglied seit: 15.03.2005



Hi Lestat,
sehr schönes Teil, gefällt mir!

Was mir auffiel:

Ich melde mich an (ohne Passwort-Speicherung), klicke etwas herum und plötzlich erscheint der Anmeldeschirm wieder:

user posted image

Wenn ich dann wieder das Passwort eingebe stürzt er ab:

user posted image

Eine Idee?

Grüsse,
moh


--------------------
24h Happy-Hour in moh's Taverne - Man sieht sich (-;
PM
Top
moh0815
Geschrieben am: 05.11.2008, 20:23
Quote Post


Jungpflanze


Gruppe: Serverbetreiber
Beiträge: 120
Mitgliedsnummer.: 13.019
Mitglied seit: 15.03.2005



Hi,
ich muss mich korrigieren:

Ich brauche nicht 'rumklicken'. So ziemlich genau 34-35 Sekunden nach dem Programmstart kommt es zu dem genannten Effekt - reproduzierbar.

Grüsse,
moh


--------------------
24h Happy-Hour in moh's Taverne - Man sieht sich (-;
PM
Top
Heino
Geschrieben am: 05.11.2008, 20:29
Quote Post


Apfelplantage


Gruppe: Members
Beiträge: 381
Mitgliedsnummer.: 5.776
Mitglied seit: 21.12.2003



QUOTE (moh0815 @ 05.11.2008, 20:23)
Ich brauche nicht 'rumklicken'. So ziemlich genau 34-35 Sekunden nach dem Programmstart kommt es zu dem genannten Effekt - reproduzierbar.

also das prob habe ich nicht

PM
Top
0190warner
Geschrieben am: 05.11.2008, 20:42
Quote Post


Apfelguru


Gruppe: Moderator
Beiträge: 5.402
Mitgliedsnummer.: 3.601
Mitglied seit: 06.07.2003



hab das jetzt alles mal unter vista probiert und keine eurer genannten symtome treten hier auf. ich lass das jetzt mal ein paar stunden laufen und melde mich wieder wenns probleme gibt.

aber im moment lüpts ohne probs icon_thumbup.gif


--------------------
bitte die FAQuser posted image und Tutorials lesen und die Sucheuser posted image benutzen |

user posted image

meine Server >>> ==> Ede's Apfelschorle I & II <==
PMEmail PosterUsers WebsiteICQ
Top
ranjid
Geschrieben am: 06.11.2008, 12:45
Quote Post


Apfelblüte


Gruppe: Members
Beiträge: 3
Mitgliedsnummer.: 17.995
Mitglied seit: 09.06.2006



So ich habe es mal drauf gemacht. Gui läuft auch so weit. Nur kommen ich nicht an die freigegeben Dateien ran
user posted image
PMEmail Poster
Top
theo_box
  Geschrieben am: 06.11.2008, 12:50
Quote Post


Apfel-Opa


Gruppe: Admin
Beiträge: 300
Mitgliedsnummer.: 25.416
Mitglied seit: 06.11.2007



So ich schließe mich mal der Runde an. Habe das GUI am laufen.

user posted image

Leider hält die Freude nicht lange an. Nach etwa 1 Minute geht nichts mehr. Ich wollte die Daten in der Freigabe mir ansehen. Leider war dort nur der Ordner aufgelistet, aber keine Daten. Und dann das:

user posted image

Nichts ging mehr. Abbruch!


--------------------
Man lebt nicht, damit am Ende Gras darüberwächst.
Jurij Brèzan

Mancher klopft mit dem Hammer an der Wand herum und glaubt, er treffe jedesmal den Nagel auf den Kopf.
J.W. v. Goethe
PM
Top
moh0815
Geschrieben am: 06.11.2008, 19:03
Quote Post


Jungpflanze


Gruppe: Serverbetreiber
Beiträge: 120
Mitgliedsnummer.: 13.019
Mitglied seit: 15.03.2005



Hi,
ich dachte erst es wär ein Vista-Problem - scheint aber bei 0190warner zu funktionieren.

Macht es ggf. einen Unterschied, ob man den Installer oder die einfache .exe verwendet?
Ich nutze letztere.
Theos Problem schein ähnlich zu sein - welches OS?

Nachher mal prüfen...

Grüsse,
moh


--------------------
24h Happy-Hour in moh's Taverne - Man sieht sich (-;
PM
Top
moh0815
Geschrieben am: 06.11.2008, 19:13
Quote Post


Jungpflanze


Gruppe: Serverbetreiber
Beiträge: 120
Mitgliedsnummer.: 13.019
Mitglied seit: 15.03.2005



Noch was:

Ich würde der Sache ja gern mehr auf den Grund gehen, leider fehlen mir die passenden Debug-Werkzeuge im betroffenen OS.
Gibt es einen (inoffiziellen) Win32-Port von KDevelop? Oder alternativ andere kompatible Win32-IDEs? Was kann man sonst tun?

Grüsse,
moh


--------------------
24h Happy-Hour in moh's Taverne - Man sieht sich (-;
PM
Top
theo_box
  Geschrieben am: 06.11.2008, 19:40
Quote Post


Apfel-Opa


Gruppe: Admin
Beiträge: 300
Mitgliedsnummer.: 25.416
Mitglied seit: 06.11.2007



Ich habe unter WinXP SP3 getestet. Unter Vista wollte ich es mir nicht antun ehrlicher gesagt. Bei mir war es egal ob ich die EXE oder MSI genommen habe. Hatte beides probiert. Es ging gar nichts mehr. Keine Rückmeldung stand nur noch da.


--------------------
Man lebt nicht, damit am Ende Gras darüberwächst.
Jurij Brèzan

Mancher klopft mit dem Hammer an der Wand herum und glaubt, er treffe jedesmal den Nagel auf den Kopf.
J.W. v. Goethe
PM
Top
Lestat
Geschrieben am: 06.11.2008, 19:41
Quote Post


Apfelkern


Gruppe: Admin a.D.
Beiträge: 87
Mitgliedsnummer.: 9.386
Mitglied seit: 29.06.2004



Ohje. Da scheint's ja noch einige Probleme zu geben.

Die Shareanzeige ist direkt meine Baustelle. Mich verwundert nur grad, dass der Anzeigefehler immer noch auftritt, den hatte ich eigentlich beseitigt.
@ theo_box: kam der Speicherzugriffsfehler während du in der Share-Anzeige warst und läuft die GUI wenn du nicht in den Tab rein gehst?

@ moh0815
Der Installer kopiert eigentlich nur die Juicer.exe in das angegebene Verzeichnis.
Das Problem mit dem Connection Lost hatte ich in einer ganz alten Version mal unter Windows, seit einigen Änderungen an der Verbindungsverwaltung allerdings nicht mehr.

Debuggen könnte man es über den gdb für Windows aus dem MinGW Projekt. Als Frontend eignet sich dabei QDevelop. KDevelop müsste aber inzwischen dank Qt4 auch nativ unter Windows laufen.

Allerdings müsstest du dann noch Juicer von den Quellen in einer Debug-Version übersetzen. Und die Qt-Libs müssen installiert sein.




Wir sind schon auf Fehlersuche. Mir selbst mangelt es allerdings momentan wegen der Arbeit nur etwas an Zeit, aber am WE schau ich dann auch mal rein. Mal schauen, ob man für einige Fehler ein Fehlerprotokoll schreiben kann. Unter meiner XP-SP2 Installation hier tritt bis auf die fehlenden Shares keiner der Fehler auf.

Btw. @ heino: was hast'n du für ne Leitung? 5000 kbytet/s? Das sind 40 MBit icon_eek.gif

Edit:
korrigiere, ist XP mit SP3 bei mir. Ein Unterschied bei mir wird wohl noch sein, dass AJ auf einem anderen Rechner und nicht lokal auf der Windows-Kiste läuft. Ich werd das am WE dann mal in VirtualBox durchtesten.

@ theo: dein arbeitsspeicher ist aber schon in Ordnung? icon_wink.gif


--------------------
From freedom came elegance - Linux Mint 7 Gloria
PMEmail PosterUsers Website
Top
theo_box
  Geschrieben am: 06.11.2008, 19:46
Quote Post


Apfel-Opa


Gruppe: Admin
Beiträge: 300
Mitgliedsnummer.: 25.416
Mitglied seit: 06.11.2007



Der Speicherüberlauf oder Speicherzugriffsfehler tritt beim klick auf einen der Reiterbutton auf. Der GUI startet normal und dann kommt die Sanduhr schon. Kurz darauf kommt noch einmal das Anmeldefenster und alles ist vorbei.


--------------------
Man lebt nicht, damit am Ende Gras darüberwächst.
Jurij Brèzan

Mancher klopft mit dem Hammer an der Wand herum und glaubt, er treffe jedesmal den Nagel auf den Kopf.
J.W. v. Goethe
PM
Top
Thema wird von 0 Benutzer(n) gelesen (0 Gäste und 0 Anonyme Benutzer)
0 Mitglieder:

Topic OptionsSeiten: (2) [1] 2  Reply to this topicStart new topicStart Poll